password API needed

Luke Kenneth Casson Leighton lkcl at
Mon May 18 19:04:48 GMT 1998

On Mon, 18 May 1998, Jeremy Allison wrote:

> Luke,
> 	I am looking through what you have done in
> passdb.c etc. You have confused functions that return
> smb_passwd entries and funtions that return sam_passwd
> entries.
> As an example :
> You now have 
> 	getsampwnam and getsampwuid returning a struct smb_passwd.

yes, jean-francois has pointed this out, too.
> This makes no sense - if they return a smb_passwd
> they should be called getsmbpwnam and getsmbpwuid (as they
> were originally).
> You then have getsam21pwnam returning a struct sam_passwd.
> This is ok.
> You need to make explicit in the function name
> what it will return.
> This means that (to stick to your current naming
> structure) anything returning a sam_passwd struct
> should be called get/setsam21XXXX(), to make it
> clear it's returning something different from a
> smb_passwd.
> All functions returning an smb_passwd must be
> called get/setsmbXXXXX.
> I will make these changes, as it will clarify a
> great deal of code.

such a name change will conflict with those functions so already named in
smbpass.c, which is why i haven't done it.

More information about the samba-technical mailing list