MAX_OPEN_FILES etc ...

Luke Kenneth Casson Leighton lkcl at switchboard.net
Tue Aug 4 21:02:07 GMT 1998


> 1. Create a new source file, files.c
> 
> 2. Move all code that handles the Files and FileFD structures into this
> source file.
> 
> 3. Provide access routines that provide access to paramenters in an object
> oriented manner
> 
> 4. Get rid of macros from header files that access Files directly.

hooray.
 
> This has a performance implication. Now, instead of CHECK_READ accessing

don't care.

> b. An appropriate naming convention for these.
> 
>    File_can_read(fnum)?
>    File_get_max_fnum()?
>    File_get_new_fnum()?

looks good. small first letter, though.  please resist the temptation of
suggestions to add a function that returns an entire Files structure entry
(for now!).  i will need to support NetrFileEnum somehow, however. 

also, richard, can you review lib/rpc/server/srv_pipe_hnd.c for me, which
i originally based on the Files[] structure?

luke



More information about the samba-technical mailing list