Can't seem to get my W2K professional WS to join Samba domain

Adrian Wallenholm adrian at
Sun Sep 16 16:06:02 GMT 2001

I have had the sambe problem for the last three weeks and haven't been able to find
a solution. The same server accepts domain logons from a non SP2 W2K, but not
from a computer where SP2 is applied.

YES! I finally solved the problem during the composition of this letter.
When trying to log on to my domain ROOMSERVICE as user "testuser"
the log.smbd told me this:

[2001/09/17 00:19:49, 0] rpc_server/srv_samr.c:api_samr_set_userinfo(672)
  api_samr_set_userinfo: Unable to unmarshall SAMR_Q_SET_USERINFO.
[2001/09/17 00:19:49, 0] passdb/smbpass.c:startsmbfilepwent_internal(87)
  startsmbfilepwent_internal: unable to open file /usr/local/samba/private/smbpasswd. Error was Permission denied
[2001/09/17 00:19:49, 0] passdb/smbpass.c:iterate_getsmbpwuid(1240)
  unable to open smb password database.

I then added root as a samba user with 'smbadduser root:root' and then tried to login again,
now the server accepted me as a member of the domain.
I've tried to work around this error message a few times before, but the idea of
logging on as root never struck me.

More information about the samba-ntdom mailing list