smbtorture help needed - testing file servers

Mike R. Cannon cannon at
Thu Nov 15 13:01:11 GMT 2001

Any thoughts on a better way to do comparative file system test would be
appreciated?  Or a better place to post question with regards to that.

I am trying to run smbtorture to compare:
NT 4.0
a propritary NAS device

I run the following command:
./smbtorture //testnt-18/data2 -N 16 -U mrcannon%passwd NBWNT

And I get results back against a NT 4 server.  Aginst the NAS and a 2000
server I get the following error repeatedly:

[2001/11/15 15:47:33, 0] lib/util_sock.c:read_socket_with_timeout(296)
  read_socket_with_timeout: timeout read. read error = Connection reset
by peer.
testnt-18 rejected the negprot (code 0)

I can mount the file system and run dbench but the servers only see that
as a single connection.  Any thoughts on why I am seeing the error, and
is there anything I can do?

Also when I run smbtorture with the "default" all tests, it will die on
the "MAXFID" test.

Thank you for your time in advance.

Mike Cannon
Infrastructure Systems Administrator
Management Information
Purdue University
1061 Freehafer Hall (FREH)
West Lafayette, IN  47907-1061

office phone: 765.494.6357
office fax: 765.496.1380
email: cannon at

More information about the samba-ntdom mailing list