Dir Ab... works with Win2K (sort of) but not with NT4

Darko Longin darkol at padd.press.net
Thu Mar 22 19:31:43 GMT 2001


We've got a subdir created on our share called "Ab...". That's with 3
full stops, tried telling users just to use 'normal' characters to no
avail. NT can not access it, error message "The folder \\blah\blah\Ab..."
does not exist. However, Win2K can access the dir but can not see any
files within it.

Created under Solaris7 on sun box with rwx for all. Samba ver 2.0.5. I've
tried the mangle case and mangle names option but it does not seem to make
a blind bit of difference. Any help greatly appreciated. Thanks

smb.conf example (not done by me)

# Global parameters
        workgroup = TRANS
        netbios name = NAME
        server string = Samba %v
        security = SHARE
        null passwords = Yes
        restrict anonymous = Yes
        log level = 2
        log file = /usr/local/samba/var/log.%U
        max log size = 2000
        keepalive = 10
        preferred master = Yes
        domain master = Yes
        invalid users = root
        admin users = someone
        short preserve case = No
        share modes = No
        mangle case = yes
        mangled names= yes

        comment = Shared Transmission Area
        path = /usr/local/production/trans
        guest account = trans
        read only = No
        guest ok = Yes
        fstype = FAT


More information about the samba-ntdom mailing list