RPC failed/No mapping...

Eric P. McCoy emccoy at hamilton.edu
Fri Jan 5 23:16:56 GMT 2001

I upgraded to the HEAD version in the hopes that it would solve other 
problems.  Now I think I'm completely where everyone else is.

Immediately after install, I tried again, and got the "No mapping..." error 
that someone else has just mentioned.  I tried changing the machine name to 
all capitals, which produced the "RPC failed" error.  I put it back and got 
the "No mapping..." error again.

Then I regenerated smbpasswd from scratch.  I noticed that the "W" flag was 
now set for the machine.  I tried unsetting it to see what would happen, 
and then it caused the "RPC failed" error.  I turned it on again, got back 
to "No mapping..." and set "W" for "root," and got the "RPC failed" 
error.  I tried enabling or disabling W for all combinations of both the 
machine and root, and whenever W was set on both or neither, it'd cause 
"RPC failed."  When it was only set for one but not the other, it'd cause 
"No mapping..."

Now, when everything is back just the way it was before, I _usually_ get 
the "RPC failed" error, but only _sometimes_ get the "No mapping..." 
error.  Bear in mind that this occurs randomly, and with no change.  (e.g., 
I can try joining the domain 15 times in a row, and 3 times I will randomly 
get "No mapping...", but all others I will get "RPC failed.")  Are some 
variables not being initialized properly?

Lastly, there was a bug in the CVS code as of when I got it this 
afternoon.  Trivial to fix, but also trivial to detect - compilation died.

Eric P. McCoy <emccoy at hamilton.edu>

"Jamaican?  I thought you were some sort of outer-space potato man!"

More information about the samba-ntdom mailing list