RPC failed/No mapping...

Armand Welsh armand at welshhome.org
Sat Jan 6 00:43:33 GMT 2001

*This message was transferred with a trial version of CommuniGate(tm) Pro*
# Samba SMB password file
apwelsh:502:numbers:numbers:[U          ]:LCT-3A53E2B9:
craig:503:numbers:numbers:[U          ]:LCT-39C6AC93:
valerie:505:numbers:numbers:[U          ]:LCT-39C6ACA3:
root:0:numbers:numbers:[U          ]:LCT-3A3876AE:
NELSON$:506:numbers:numbers:[W          ]:LCT-3A387A97:
nrfan:507:numbers:numbers:[U          ]:LCT-3A47951C:

also, passwd:

and, group:

(filtered to protect my system :)  )

now, what I do, is I delete the machine entry from smbpasswd, and the I add
it manually, as the FAQ states.  After creating the entry manually, I also
delete the root user entry from smbpasswd.  Then I create a new root user
entry, "smbpasswd -a root", then just to be safe, I use "smbpasswd -e root",
and lastly I set a password for root with "smbpasswd root".  Creating the
machine trust account, is as simple as "smbpasswd -a -m NELSON$" (from the

Then I reboot the win2K machine, log in locally as administrator, join the
computer onto the domain, when it asks for the domain, I enter the domain,
in all upper case, when it asks for authentication, I enter root for user
name, and the password I created with smbpasswd for root.  Sometimes it
doesn't work 1st try.  If it failed, then I just try again.  After a few
tries, it joins me into the domain.

----- Original Message -----
From: "Eric P. McCoy" <emccoy at hamilton.edu>
To: <samba-ntdom at lists.samba.org>
Sent: Friday, January 05, 2001 3:16 PM
Subject: RPC failed/No mapping...

> *This message was transferred with a trial version of CommuniGate(tm) Pro*
> I upgraded to the HEAD version in the hopes that it would solve other
> problems.  Now I think I'm completely where everyone else is.
> Immediately after install, I tried again, and got the "No mapping..."
> that someone else has just mentioned.  I tried changing the machine name
> all capitals, which produced the "RPC failed" error.  I put it back and
> the "No mapping..." error again.
> Then I regenerated smbpasswd from scratch.  I noticed that the "W" flag
> now set for the machine.  I tried unsetting it to see what would happen,
> and then it caused the "RPC failed" error.  I turned it on again, got back
> to "No mapping..." and set "W" for "root," and got the "RPC failed"
> error.  I tried enabling or disabling W for all combinations of both the
> machine and root, and whenever W was set on both or neither, it'd cause
> "RPC failed."  When it was only set for one but not the other, it'd cause
> "No mapping..."
> Now, when everything is back just the way it was before, I _usually_ get
> the "RPC failed" error, but only _sometimes_ get the "No mapping..."
> error.  Bear in mind that this occurs randomly, and with no change.
> I can try joining the domain 15 times in a row, and 3 times I will
> get "No mapping...", but all others I will get "RPC failed.")  Are some
> variables not being initialized properly?
> Lastly, there was a bug in the CVS code as of when I got it this
> afternoon.  Trivial to fix, but also trivial to detect - compilation died.
> --
> Eric P. McCoy <emccoy at hamilton.edu>
> "Jamaican?  I thought you were some sort of outer-space potato man!"

More information about the samba-ntdom mailing list