Samba 2.2.2 PDC Logon with Windows XP Professional

James W. Beauchamp jbeauchamp at
Wed Dec 19 06:17:36 GMT 2001

I believe this is the XP SignorSeal issue.  In your source files you will
find a .reg file that is named xpsignorseal or something like that.


I have the exact same problem except with a Win2K machine and I haven't been
able to figure it out yet.


----- Original Message -----
From: Warren Shepherd
To: samba-ntdom at
Sent: Tuesday, December 18, 2001 1:18 PM
Subject: Samba 2.2.2 PDC Logon with Windows XP Professional


I've got a problem with Windows XP Pro logging into a Samba 2.2.2 PDC.
Unfortunately it's a production server so it's very urgent that I fix this,
people complaining, etc.

I got through various hassles of problems with joining the domain, however
the XP Pro workstation in question (named 'Century') has now successfully
joined the domain, showing the "Welcome to the Zylex domain" dialog box. The
computer has successfully rebooted as it says it should with the "You must
restart for the changes to take effect - yes/no" box.

After the reboot however when you try to login to the domain, the following
dialog box is displayed.

Logon Message:
Windows cannot connect to the domain either because the domain controller is
down or otherwise unavailable, or because your computer account was not
found. Please try again later. If this message continues to appear, please
contact your system administrator for assistance.

There's no noticeable delay in between hitting enter and the box being

I've made a computer account on the Samba PDC using the following commands:

useradd -s /bin/false -d /dev/null century\$ (also tried without the slash
just incase).
Smbpasswd -a -m century

Samba has been restarted at every stage. Various configurations have been
tried (including encrypt passwords being on and off). WinXP SignOrSeal is
off (Registry patch applied, and changed manually). My 98SE Laptop can log
into it fine with the same username and password I am using to log into this
machine. The 98 machine is not logged in when I'm trying to log into this
one. I've had multiple 9x machines logging into the domain successfully.

What am I missing? Can anybody help me?

More information about the samba-ntdom mailing list