Still having SCO problems

Trevor Antczak trevor at
Thu May 11 15:01:45 GMT 2000


I'm still trying to compile on this damn SCO box.  I was finally able to
get configure to work, but now make fails.  When I type make and hit
enter I get an immediate error (it does not appear to try to compile
anything) saying that "function getcwd is not implanted"  A quick grep
of ./source/lib tells me that the only C call to getcwd is in system.c
(It's mentioned in a comment in doscalls.c) configure looks for it, but
it is never mentioned in mt Makefile.  Since I don't think make is even
trying to compile anything, I am getting a bit confused.  Should I try
to comment out the call in system.c?  Will it break Samba?  I don't even
think that make is looking at system.c (at any rate it doesn't say so).
My boss has already nixed switching OS's, so that is out I tried
./configure --enable-shared=no as Luke suggested, no luck.  I've never
installed a compiler from scratch before, and SCO makes it exceedingly
difficult from what I can tell.  I am running out of ideas.  I tried a
SCO newsgroup, but succeeded in little other than getting flamed.  I
gotta say- If SCO was the alternative, I begin to see how NT got a
foothold.  If anyone has any further ideas, I would greatly appreciate
them.  This is TNG 2.5, trying to compile on SCO Open Server 5.04 with
gcc 2.95.

Thank you,
Trevor Antczak
Technology Manager
Steinmetz & Associates

More information about the samba-ntdom mailing list