Problems with PDC on HPUX10.20

Elias Afxentiou eafxent at
Tue Jul 27 16:51:15 GMT 1999

I have compiled the prealpha code and it runs smoothly as a domain
controller on samba. When I combile it on HPUX10.20 it compiles just fine
(with no special options, just ./configure -> make) but nothing seems to
work. I tried running it at debug level 3 and I get these messages in the
samba.smb file:

[1999/07/27 09:22:57, 2] lib/interface.c:interpret_interfaces(213)
  Added interface ip= bcast= nmask=
[1999/07/27 09:22:57, 1] smbd/files.c:file_init(219)
  file_init: Information only: requested 10000 open files, 1014 are
[1999/07/27 09:22:57, 0] smbd/dfs.c:init_dfs_table(128)
  No DFS map, Samba is running in NON DFS mode
[1999/07/27 09:22:57, 3] smbd/server.c:main(709)
  loaded services
[1999/07/27 09:22:57, 3] smbd/server.c:main(717)
  Becoming a daemon.
[1999/07/27 09:22:57, 3] lib/util_sock.c:open_socket_in(675)
  bind succeeded on port 139
[1999/07/27 09:22:57, 2] smbd/server.c:open_sockets(186)
  waiting for a connection
[1999/07/27 09:22:57, 0] lib/fault.c:fault_report(40)
[1999/07/27 09:22:57, 0] lib/fault.c:fault_report(41)
  INTERNAL ERROR: Signal 11 in pid 21672 (2.1.0-prealpha)
  Please read the file BUGS.txt in the distribution
[1999/07/27 09:22:57, 0] lib/fault.c:fault_report(43)
[1999/07/27 09:22:57, 0] lib/util.c:smb_panic(2527)
  PANIC: internal error

smbd seems to be dying constantly because of the above reason, on top of
everything I get the following error when I run the smbpasswd program as
root (to initialize the smbpasswd file(add myself), the file does not
exist yet):
# ./smbpasswd -a eafxent
error connecting to (Invalid argument)
cli_establish_connection: failed to connect to TETANUS<00> (
error connecting to (Invalid argument)
cli_establish_connection: failed to connect to TETANUS<00> (
cli_connect_serverlist: Domain password server not available.
get_domain_sids: unable to initialise client connection.
Can't setup password database vectors.

I should also mention that the testparm runs fine, I am using security =
user, and I am starting smbd and nmbd as daemons (until I get it all
working that is and then I will put them in inetd)
	Any help will be greatly appreciated. I can't hurt my head any
more, three days of bitting it on the wall have proven a hard thing to
deal with.
	Elias Afxentiou.

(I can also send my smb.conf file if needed)

More information about the samba-ntdom mailing list