Cannot add a printer (NT4SP3 + latest cvs samba)

Gerald W. Carter cartegw at Eng.Auburn.EDU
Sun Jun 14 22:03:25 GMT 1998

On Sun, 14 Jun 1998, Andy Smith wrote:

> > On Sun, 14 Jun 1998, Pierre-Jules Tremblay wrote:
> > 
> > > Using the current (98/6/13 - 18:00 EDST) cvs'ed version of samba, I
> > > tried to add a printer through the "Add printer" dialog in Windows NT
> > > 4.0 Workstation, service pack 3.  Typed in the name of the printer
> > > share using its UNC path.  I got an error message saying that "Could
> > > not connect to the printer.  The printer name is invalid.".  
> I have the same problem, but find that if it doesn't connect using the
> add printer wizzard, if I browse to the printer in network
> neighbourhood, things generally work right after that.  Sometimes I
> have to attempt the connection serveral times, and there is still one
> printer which refuses a connection from some wkstns, so if you have a
> workaround could you let me know as well please.

OK.  Here a quick and dirty fix.  the NT box needs to be coaxed to back
down from the MSRPC calls to use the LanMan calls.  Add the printer
locally but connect it to the LanMan port which you have created ( rather
than LPT1: )

To create the LanMan port, modify the following registry script for your
site and import it...


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services]
"DisplayName"="LanMan Print Services"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Monitors]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Monitors\LanMan Print Services Port]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\PortNames]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Servers]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Servers\lab1]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers\LanMan Print Services\Servers\lab1\Printers]


You may have to reboot the NT machine to get these ports to show up.  I
have tried this and it seems to work.  Let me know how if goes.  If it is
an acceptable solution, the I will add it to the FAQ for now.

Hope this helps,
                            Gerald ( Jerry ) Carter	
Engineering Network Services                           Auburn University 
jerry at   

       "...a hundred billion castaways looking for a home."
                                  - Sting "Message in a Bottle" ( 1979 )

More information about the samba-ntdom mailing list