machine inaccessible - how to fix??

Luke Kenneth Casson Leighton lkcl at
Thu Apr 16 12:36:42 GMT 1998


when a machine joins a domain, it is allocated a "machine trust account".
on samba, you do this by running "smbpasswd -add --machine

if these passwords get out of sync between the PDC and the workstation,
then you will run into difficulties: the _machine_ not the user will be
refused access to the domain.  this is to stop people spoofing access from
unauthorised machines. 

exactly how you recalibrate a machine to get it to rejoin a domain with a
default password i wouldn't like to say: the techniques i used are
inadviseable.  i suggest you change the name of the NT workstation as the
safest method, and re-join the domain with the new name.


On Thu, 16 Apr 1998, John Harper wrote:

> I know this question doesn't really belong in this list but on the
> other hand my troubles began when I was playing with NT domains served
> by Samba, so maybe someone else messed things up the same way....
> I originally had my NT client doing domain logins to one Samab PDC
> called "banks" (which also offered some shares such as home
> dirs). This worked fine until I found out a client machine can only be
> in one domain. So I removed the NTDOM branch, put back the original
> Samba, and moved the PDC to another machine.
> I did a domain login from my NT client and it seemed to work ok
> (except I did not share homes, so it could not find the roaming
> profiles). But now when I attempt to connect to "banks" (the former
> PDC) through the Network 'hood I get the error message "machine is
> inaccessible. The storage control blocks have been destroyed". This
> happens for any user on this client.
> >From this client I can connect to any other Samba server, and any
> other client machine can connect to banks, and as well I can connect
> to banks from my client with net use.
> After the failed attempt to connect via the Net'hood a net use shows
> two IPC connections:
> \\Banks\IPC$
> The Samba logs show nothing unusual (that I can understand - there are
> no error messages at any rate).
> I've reinstalled the samba client on banks, I've even changed the
> netbios name and it still doesn't work. I've converted my client back
> to it's original config without domain logins, and it still fails. I
> turned off the PDC - in fact everything is now back the way it was
> before I ever heard of NT domains..... it's still broke. I could move
> to another client machine, but if I trash that too, well..
> I've had no responses from other groups; the M$ web site only
> references "storage control blocks" twice (once on a list of NT error
> codes....); no book on NT mentions this. 
> So... has anyone ever heard of this? Is there a way to fix it short of
> re-installing NT?
> Thanks in advance.
> John Harper
> ------------------------------------
> Academic Computing Coordinator
> University of Toronto at Scarborough
> harper at

More information about the samba-ntdom mailing list