OS X and rsync: unpack_smb_acl errors and --numeric-ids

Kevin Korb kmk at sanitarium.net
Fri May 30 18:58:54 MDT 2014

Hash: SHA1

I just took a look at the patches again and I bet the first one (the
less elegant one) would work for you.  You would have to try it on
3.0.7 though since 3.0.8 includes the other patch.

On 05/30/2014 08:15 PM, Kyle Crawford wrote:
> It does sound like the same issue, however I definitely still see
> the issue on 3.0.9 and 3.1.1pre1 on OS X.
> Kyle
> Sent from Mobile
>> On May 30, 2014, at 8:04 PM, Kevin Korb <kmk at sanitarium.net>
>> wrote:
> Have you tried on the current version?  A similar problem was
> handled a while ago:
> https://bugzilla.samba.org/show_bug.cgi?id=8020
> On 05/30/2014 07:59 PM, Kyle Crawford wrote:
>>>> First of all.  Thank you rsync developers and maintainers for
>>>> all of your work.  It is awesome.  I love rsync.  I can't
>>>> thank you enough.
>>>> So this has been brought up before: 
>>>> https://lists.samba.org/archive/rsync/2010-April/024941.html
>>>> We are getting this error:
>>>> stderr: rsync: unpack_smb_acl: sys_acl_get_info(): Undefined
>>>> error: 0 (0)
>>>> due to ACL entries that can not be resolved by name at the
>>>> time when rsync attempted to resolve them.
>>>> This results in an exit status of 23.
>>>> The reason the ACL entry can not be resolved by name could be
>>>> that a network directory service like LDAP or Active
>>>> Directory is having issues. Or it could be that the user or
>>>> group no longer exists (locally or in a network directory
>>>> service).
>>>> On OS X, when this happens, the UUID of the group is
>>>> displayed instead of the user or group in an ls -le for
>>>> example:
>>>> host:~$ ls -le 
>>>> /Volumes/Src/81-access-control-lists-missing-user-and-group/acl-test-2
- -rw-r--r--+ 1 root  wheel  0 May 30 13:01
>>>> /Volumes/Src/81-access-control-lists-missing-user-and-group/acl-test-2
0: 4D429A34-54A4-48F2-A9AB-9D1E7D1E6738 allow read
>>>> 1: 1E0D050D-973C-47C4-8ACE-D900B04B986D allow read
>>>> Or you can see the UUID using ls -len  (numeric).
>>>> So when I am transferring from OS X to OS X, I'd like these
>>>> UUIDs to just get transferred as UUIDs the same way that
>>>> --numeric-ids works.
>>>> That way I can get a nice exit status of 0 and have
>>>> confidence in my backups.
>>>> Mr. Bombich has worked around this issue and even posted a
>>>> patch back in 2011.
>>>> http://help.bombich.com/discussions/questions/2248-warning-messages-from-rsync-307
However, the patch has not been updated (that I know of).
>>>> And while I was able to apply the patch to rsync 3.0.6 and
>>>> maybe 3.0.7, those versions are quite old and I'm noticing
>>>> that creation times preservation is not working for me on
>>>> those even though I apply the crtimes patch.
>>>> I would like to see --numeric-ids handle this by transferring
>>>> the UUID rather than attempting to resolve the user/group.  I
>>>> don't know how this would work for other platforms/mixed
>>>> platforms or if there is a way to detect the source and
>>>> destination OS for enabling this.
>>>> Thoughts?  Should I post this as a feature request?
>>>> Thanks,
>>>> Kyle
>> -- Please use reply-all for most replies to avoid omitting the
>> mailing list. To unsubscribe or change options:
>> https://lists.samba.org/mailman/listinfo/rsync Before posting,
>> read: http://www.catb.org/~esr/faqs/smart-questions.html

- -- 
	Kevin Korb			Phone:    (407) 252-6853
	Systems Administrator		Internet:
	FutureQuest, Inc.		Kevin at FutureQuest.net  (work)
	Orlando, Florida		kmk at sanitarium.net (personal)
	Web page:			http://www.sanitarium.net/
	PGP public key available on web site.
Version: GnuPG v2.0.22 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/


More information about the rsync mailing list