rsync for windows doesn't like "--rsh"?

Kevin Korb kmk at
Sun May 25 21:10:29 MDT 2014

Hash: SHA1

It is expecting something command line compatible with [rs]sh which I
am pretty sure openssl is not.

On 05/25/2014 10:47 PM, Jason Haar wrote:
> Hi there
> I'm trying to get rsync for windows (tried two versions) to call
> "--rsh" so I can pipe rsync through openssl.exe. When I run it I
> get
> The process tried to write to a nonexistent pipe.
> So it looks like the CMD file I have that calls openssl.exe isn't 
> joining up with rsync.exe? As rsync.exe defaults to calling
> ssh.exe, and I can even successfully call it via "rsync.exe --rsh
> ssh.exe", that makes me think the problem is with either my tiny
> CMD file or openssl.exe not "piping" correctly? Buffering issues
> perhaps?
> Can anyone help this poor old Unix guy out on Windows? :-)
> Thanks

- -- 
	Kevin Korb			Phone:    (407) 252-6853
	Systems Administrator		Internet:
	FutureQuest, Inc.		Kevin at  (work)
	Orlando, Florida		kmk at (personal)
	Web page:
	PGP public key available on web site.
Version: GnuPG v2.0.22 (GNU/Linux)
Comment: Using GnuPG with Thunderbird -


More information about the rsync mailing list