backup-dir over nfs

Philippe LeCavalier support at
Thu Mar 6 08:36:27 MST 2014

Hi All.

Since it's a lengthy one to explain, I'll jump right into my issue:

I run rsync on 3 debian systems for the purpose of backing up approximately
500GBs of various types of data. The general strategy is two systems hold
full backups and the third holds incremental's using date-based --backup
--backup-dir=. The directory in question is an NFS mount.

Here's the problem: randomly but shortly after the sync starts, it hangs.
At this point, the NFS host(hosting the --backup-dir) responds just fine.
However, the rsync host can only be accessed via console(no ssh, no
ping...Nothing). Now here's the kicker: once I access the rsync host, it
resumes the transfer as if it was waiting to be wakened. If I stay logged
in and wait for it to hang again, all that is required for the sync to
resume is a touch of the keyboard again, as if it was somehow waiting to be

One important thing I should mention is if I unmount the NFS share and run
the command with the --backup-dir to the local filesystem on the rsync host
it runs as expected. Furthermore, I can confirm that I can rsync large
amounts of data in both directions via the same NFS share with a plain
rsync -a /local/dir nfs/share/dir. To me this rules out any physical and/or
config issues in the LAN and on the hosts.

All three systems are in the same subnet in my local LAN. The original data
is being pulled from various remote locations over ssh. However, I should
also mention that I've tried the same command using a USB drive and
experienced the exact same "hang". So in my mind that rules out the origin
of the data as being a potential source of the issue.

Thanks, Phil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list