Concern: rsync failing to find some attributes in a file transfer?

L. A. Walsh rsync at
Sat Jul 26 07:19:11 MDT 2014

Kevin Korb wrote:
>> I ran the util and have gotten odd results each time I ran it.
> What util?  What results?
Besides the ones I included in the previous email, I ALSO experienced this:
(from bug

   "The above was just a toy example designed to illustrate the issue.  In
     practice, rsync 3.1.1 left dozens of such "ghost" directories inside my


I ran out of space because of it... creating well over 100,000 empty
directories that took up 400M space (on a 600M partition).  I thought
it might have been a fluke which was why I didn't bother to detail
it, but seeing this report -- pretty much cinches it.

Copying the command from below as run from my script:

>> my $rcmd = [$Rsync]; push( @$rcmd, qw( --8-bit-output --acls
>> --archive --hard-links --human-readable --no-inc-recursive
>> --one-file-system --prune-empty-dirs --whole-file --xattrs ), 
>> "--compare-dest=$base_lvh->fs_mp/.");
So I am comparing a "today" snapshot with yesterday's and dumping the 
to a third partition.

So that's the other "weirdness" I was seeing.  Do you have a better picture

More information about the rsync mailing list