cannot rsync when source directory lacks write permission

András Porjesz andras.porjesz at
Fri Aug 10 05:46:56 MDT 2012

Hi Berny,
Yes, it is a possible solution, I missed something. But from my point of view you did not get my point. 
I worked with unix/linux for 20 years therefore I know what are you talking about. In some cases using nobody is acceptable or even preferred, but in the specified case it is still an annoying and confusing bug. If you would like to say: this is not user friendly at all, and furthermore the documentation is not clear enough, misinterpretable (it is not mentioned anywhere: the cliend side settings or server side settings or some default assumptions have priority). My assumtion was defaults only used when required, but as I wrote already, rsyncd overkills client side settings.

You tried to explain nobody is normal as default - and I accept it, I tried to explain overwriting/ignoring -perms is a bug...


-----Original Message-----
From: Voelker, Bernhard [mailto:bernhard.voelker at] 
Sent: Friday, August 10, 2012 10:01
To: András Porjesz; Steven Levine; rsync at
Subject: RE: cannot rsync when source directory lacks write permission

András Porjesz wrote (Friday, August 10, 2012 9:27 AM):

> I think all the permission/ownership handling is complicated 
> (unaccountable, puzzling, peculiar) and the usage is confusing and 
> annoying

I think you didn't get Steven's point:

>>              [...] The default is
>>              uid -2, which is normally the user nobody.

I.e. even if your rsyncd is running as root, it drops it's priviledges by default by becoming 'nobody'.

That is a pre-cautious security issue which meets the requirements for most installations which just serve files read-only.

When you want to push things there, then you might either rsync-via-ssh to that server as root (or sudo there), or set 'uid' to root in rsyncd.conf.

Have a nice day,

More information about the rsync mailing list