--delete and --files-from

Leon Castellanos lcastellanos at mentora.com
Mon May 24 09:50:09 MDT 2010


I've read as much as I can regarding the many problems people seem to have with -delete and none of the solutions seems to work for me.

I have tried all combinations of using the trailing slash but it seems to have no effect.

Does anyone know if -delete can work with -files-from?

Here's the code:

find $DIR/lvl1 -maxdepth 1 -type f -mmin +30| /usr/bin/awk -F/ '{print $8"/"$9}' > /tmp/$FILES;
rsync -ptrgoz --stats --delete --files-from=/tmp/$FILES $DIR/ $RDEST/

As I mentioned above I have tried all combinations of $DIR/ $DIR $RDEST/ $RDEST

The rsyncd.conf on the other end:

path = /mnt/backup/machine
read only = false
transfer logging = yes
uid = 0

Here too I tried the trailing slash with no effect.

Any pointers will be greatly appreciated...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.samba.org/pipermail/rsync/attachments/20100524/038365f6/attachment.html>

More information about the rsync mailing list