invalid uid os x

Mac User FR macuserfr at
Sat Jan 23 02:25:31 MST 2010

I don't have any help for the solution of your uid problem, but try upgrading to a recent rsync version.

1) Download and Install XCode if not already done
2) Download sources from rsync server
3) unzip
4) open a Terminal on the rsync sources folder
5) run "./configure && make"
6) try using the fresh compiled rsync instead of built-in one.

Personally, I dislike Apple version of rsync because of the extended resources patch they made isn't compatible with the one further adopted by rsync. So, to have multiplatform extended attributes functionality you should replace Apple's rsync by a new version. As my main interest in rsync is to run it over any OS (I run it fine in OS X >= 10.4, Windows XP/2003, linux, freebsd).

Hope this help you to find a solution.

Best regards,


Le 22 janv. 2010 à 22:54, John Abraham a écrit :

> I have a strange problem on OS X server.   I start the rsync daemon manually using
> su
> rsync --daemon
> (or sudo rsync --daemon)
> and it works for a while.  But eventually, when people try to connect, they get an "invalid uid" error.  The uid is the once specified in the profile in rsyncd.conf .
> If I kill the daemon process (kill -9) then restart it, it all works again.
> Anyone else run across this?
> I need to restart the daemon every day or so.  It might have something to do with me logging out of OS X, then logging back in.  But it's rather strange.  And google isn't helping me.  I tried searching the web and the mailing list archives but didn't have any luck.
> This is the default version of rsync on OS X snow leopard server, which is rsync  version 2.6.9  protocol version 29.  My rsync userids are local machine ID's, not LDAP ID's, but that shouldn't matter, I don't think.
> --
> John 
> -- 
> Please use reply-all for most replies to avoid omitting the mailing list.
> To unsubscribe or change options:
> Before posting, read:

More information about the rsync mailing list