Another cygwin/rsync question

Ken Smith kens at
Wed Jan 20 05:14:36 MST 2010

> On Mon, Jan 18, 2010 at 23:37, Ken Smith<kens at>  wrote:
>> Hi, Been using rsync for many years but I'm stuck with this problem.
>> I'ts a simplistic backup using rsync from a Windows 2k3 machine to a Linux
>> box out on the 'net, using pre-shared ssh keys. In this case I'm saving,
>> files belonging to various users, using the administrator account on the
>> windows machine and the destination is a normal user account and its home
>> file area. I'm using the rsync --chown option to stop rsync trying to change
>> the ownership/mode on the destination filesystem. I'm not bothered about
>> saving the file perms/ownership.
>> If I do a small transfer of a couple of dozen files as a test, all goes
>> well.
>> The path of the source on the windows system has spaces in the name, I've
>> tried every type of escaping that I can think of to get the shells to work
>> properly. If I run rsync running on a larger batch of files it seems to
>> stall. Using the -vvv option I can see rsync, on the windows.cygwin end,
>> collecting a list of files prefixed by
>> [sender] make_file (filenames)
>> that I guess it is going to transfer and then this is followed by
>> recv_file_name (another filename)
>> Which I presume is the first file that it is transferring. That file is a
>> few hundred k so it won't take long, But rsync stalls at that point. Cntrl C
>> does nothing and I end up having to kill the rsync process.
>> I've tried
>>   rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i
>> /home/administrator/rsync-key" """"/cygdrive/c/Users Shared Folders""""
>> """"user at remotehost/home/user/backup/""""
>>   rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i
>> /home/administrator/rsync-key" """"/cygdrive/c/Users\ Shared\ Folders""""
>> """"user at remotehost:/home/user/backup/""""
>> rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i
>> /home/administrator/rsync-key" '"/cygdrive/c/Users\ Shared\ Folders"'
>> '"user at remotehost:/home/user/backup/"'
>>   rsync -avvvz --progress --delete --chmod=ugo=rwX -e 'ssh -i
>> /home/administrator/rsync-key' /cygdrive/c/Users\\\ Shared\\\ Folders
>> user at remotehost:/home/user/backup/
>> The cygwin rsync is v3.0.6 and the Linux (Centos) target machine has rsync
>> 2.6.8
>> Any ideas most welcome.
>> Thanks
>> Ken
>> --
>> This message has been scanned for viruses and
>> dangerous content by MailScanner, and is
>> believed to be clean.
>> --
>> Please use reply-all for most replies to avoid omitting the mailing list.
>> To unsubscribe or change options:
>> Before posting, read:
> 夏凯 wrote:
>> i think /cygdrive/c/Users\ Shared\ Folders or "/cygdrive/c/Users
>> Shared Folders" is just enough. you have too many escapes, one is
>> enough. it's not a rsync problem, it's a problem about how escape
>> works.
>> and you can use filename completion, you can just enter
>> /cygdrive/c/Users or “/cygdrive/c/Users, then press tab button, then
>> it will give you /cygdrive/c/Users\ Shared\ Folders or
>> "/cygdrive/c/Users Shared Folders"
Thanks for your help. I think you are right about the escaping. I've 
been experimenting a bit further and came to a similar conclusion.

Here's a log of what happens

$ rsync -avvz --progress --delete --chmod=ugo=rwX -e 'ssh -i 
/home/administrator/rsync-key' "/cygdrive/c/Users Shared Folders" 
user at remotehost:/home/user/backup/
opening connection using: ssh -i /home/administrator/rsync-key -l user 
remotehost rsync --server -vvlogDtprze.iLs --delete . /home/user/backup/
building file list ...
15972 files to consider
deleting in Users Shared Folders
deleting Users Shared Folders/folder/filename
deleting Users Shared Folders/Username/Application 
Data/Microsoft/Internet Explorer/file1
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
deleting Users Shared Folders/Username/Application 
delta-transmission enabled
Users Shared Folders/folder/
Users Shared Folders/folder/file12 is uptodate
Users Shared Folders/folder/file13 is uptodate
Users Shared Folders/folder/file14 is uptodate
Users Shared Folders/folder/file15 is uptodate
Users Shared Folders/folder/file16 is uptodate
Users Shared Folders/folderfile17.xls
        32768   1%    0.00kB/s    0:00:00

That last file is a few hundred k and the process stops at that point. 
I've never waited to see what happens long term, but there seems to be 
no network traffic and the ssh/rsync process on the cygwin (sending) end 
are maxing out the processor there.

On the linux destination box the file is there like this

-rw-------  1 user user      0 Jan 20 11:54 .file17.xls.ClYwWr

Is there any chance something like Symantec AV is getting in the way :-(



This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the rsync mailing list