Another cygwin/rsync question

夏凯 walkerxk at
Tue Jan 19 04:47:14 MST 2010

i think /cygdrive/c/Users\ Shared\ Folders or "/cygdrive/c/Users
Shared Folders" is just enough. you have too many escapes, one is
enough. it's not a rsync problem, it's a problem about how escape
and you can use filename completion, you can just enter
/cygdrive/c/Users or “/cygdrive/c/Users, then press tab button, then
it will give you /cygdrive/c/Users\ Shared\ Folders or
"/cygdrive/c/Users Shared Folders"

On Mon, Jan 18, 2010 at 23:37, Ken Smith <kens at> wrote:
> Hi, Been using rsync for many years but I'm stuck with this problem.
> I'ts a simplistic backup using rsync from a Windows 2k3 machine to a Linux
> box out on the 'net, using pre-shared ssh keys. In this case I'm saving,
> files belonging to various users, using the administrator account on the
> windows machine and the destination is a normal user account and its home
> file area. I'm using the rsync --chown option to stop rsync trying to change
> the ownership/mode on the destination filesystem. I'm not bothered about
> saving the file perms/ownership.
> If I do a small transfer of a couple of dozen files as a test, all goes
> well.
> The path of the source on the windows system has spaces in the name, I've
> tried every type of escaping that I can think of to get the shells to work
> properly. If I run rsync running on a larger batch of files it seems to
> stall. Using the -vvv option I can see rsync, on the windows.cygwin end,
> collecting a list of files prefixed by
> [sender] make_file (filenames)
> that I guess it is going to transfer and then this is followed by
> recv_file_name (another filename)
> Which I presume is the first file that it is transferring. That file is a
> few hundred k so it won't take long, But rsync stalls at that point. Cntrl C
> does nothing and I end up having to kill the rsync process.
> I've tried
>  rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i
> /home/administrator/rsync-key" """"/cygdrive/c/Users Shared Folders""""
> """"user at remotehost/home/user/backup/""""
>  rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i
> /home/administrator/rsync-key" """"/cygdrive/c/Users\ Shared\ Folders""""
> """"user at remotehost:/home/user/backup/""""
> rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i
> /home/administrator/rsync-key" '"/cygdrive/c/Users\ Shared\ Folders"'
> '"user at remotehost:/home/user/backup/"'
>  rsync -avvvz --progress --delete --chmod=ugo=rwX -e 'ssh -i
> /home/administrator/rsync-key' /cygdrive/c/Users\\\ Shared\\\ Folders
> user at remotehost:/home/user/backup/
> The cygwin rsync is v3.0.6 and the Linux (Centos) target machine has rsync
> 2.6.8
> Any ideas most welcome.
> Thanks
> Ken
> --
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
> --
> Please use reply-all for most replies to avoid omitting the mailing list.
> To unsubscribe or change options:
> Before posting, read:

contact me:
MSN: walkerxk at,walkerxk at
GTALK: walkerxk at

More information about the rsync mailing list