rsync/cwgwin hangs during transfers

Steven Hartland killing at
Sun Jan 17 06:44:04 MST 2010

We've never been able to use rsync on cygwin reliably. We tried loads of
things and whenever its been brought up on the cygwin list, the answer has
always been that its down to issues with pipes implementation, which was a
short coming of the underlining OS so nothing that could be fixed.

The frequency of the issue does seem to be dependent on quite a few things
including what rsync flags are in use, how fast the connection is between
the machines, what the target / source OS is and the very nature of the
files i.e. many small, few large etc.

If you want a reliable solution on windows which keeps ssh support I would
suggest using sfu. We've never had any problems with that aside from its
limitation on file size for the older 32bit OS's such as XP to under 2GB.

----- Original Message ----- 
From: "Alan C. Bonnici" <chribonn at>

> Thanks Steve. Version 1.5 of cygwin has worked flawlessly for me for years.
> That could be a solution as well (downgrade).

This e.mail is private and confidential between Multiplay (UK) Ltd. and the person or entity to whom it is addressed. In the event of misdirection, the recipient is prohibited from using, copying, printing or otherwise disseminating it or any information contained in it. 

In the event of misdirection, illegible or incomplete transmission please telephone +44 845 868 1337
or return the E.mail to postmaster at

More information about the rsync mailing list