webdav timeout

Matt McCutchen matt at mattmccutchen.net
Tue Jan 13 00:57:13 GMT 2009

 On Sat, 2009-01-10 at 18:16 +0100, Kraak Helge wrote: 
> I tried to sync two files (50 MB and 100 MB) with my webdav folder  
> using rsync 3.0.5 with Mac OS X (10.4.11) Terminal and X11. With the  
> Terminal application the sync always failed with both files. With X11  
> I once was successful synchronizing the 50 MB file. The error message  
> is always like this (also when I set the timeout to eg. 7200 seconds):
> io timeout after 1003 seconds -- exiting
> rsync error: timeout in data send/receive (code 30) at io.c(200)  
> [sender=3.0.5]
> the sync command I used:
> /usr/local/bin/rsync --size-only --human-readable --progre
> ss --recursive   --delete --timeout=1000 --bwlimit=70  --times -- 
> stats  /Users/
> Helge/temp   /Volumes/helgekraak/ >> /users/Helge/Pictures/ 
> rsync_Pictures_` dat
> e +%Y_%m_%d__%H_%M`.log
> I also tried two other webdav services with the same result. When I  
> use the Finder to copy the files it works perfectly. Also when I use  
> the cp command in the Terminal respectively with X11.
> Do you think this is a bug of rsync? Should I file an issue?

Rsync tends to run into inadequacies in network filesystems more often
than cp since it is a more sophisticated tool.  Please obtain a system
call trace of all three rsync processes using ktrace so I can see how
rsync is hanging and determine whether the fault is with rsync or the
WebDAV program.


More information about the rsync mailing list