webdav timeout

Kraak Helge helge.kraak at arcor.de
Sat Jan 10 17:16:01 GMT 2009


I tried to sync two files (50 MB and 100 MB) with my webdav folder  
using rsync 3.0.5 with Mac OS X (10.4.11) Terminal and X11. With the  
Terminal application the sync always failed with both files. With X11  
I once was successful synchronizing the 50 MB file. The error message  
is always like this (also when I set the timeout to eg. 7200 seconds):

io timeout after 1003 seconds -- exiting
rsync error: timeout in data send/receive (code 30) at io.c(200)  

the sync command I used:

/usr/local/bin/rsync --size-only --human-readable --progre
ss --recursive   --delete --timeout=1000 --bwlimit=70  --times -- 
stats  /Users/
Helge/temp   /Volumes/helgekraak/ >> /users/Helge/Pictures/ 
rsync_Pictures_` dat
e +%Y_%m_%d__%H_%M`.log

The log file (shortened):

sending incremental file list
        6.15K 100%    0.00kB/s    0:00:00
        6.15K 100%    0.00kB/s    0:00:00 (xfer#1, to-check=2/4)
       32.77K   0%    0.00kB/s    0:00:00
       98.30K   0%   59.87kB/s    0:14:25
      163.84K   0%   58.58kB/s    0:14:42
      229.38K   0%   59.10kB/s    0:14:34
       49.64M  95%   53.93kB/s    0:00:41
       51.71M  99%   57.12kB/s    0:00:03
       51.81M  99%   57.97kB/s    0:00:01
       51.87M  99%   58.44kB/s    0:00:00
       51.89M 100%   53.96kB/s    0:15:38 (xfer#2, to-check=1/4)

Thumb64.data is the 100 MB file which doesn't start to upload after  
the Layout_BM.psd file.

I also tried two other webdav services with the same result. When I  
use the Finder to copy the files it works perfectly. Also when I use  
the cp command in the Terminal respectively with X11.

Do you think this is a bug of rsync? Should I file an issue?

Thanks in advance!


More information about the rsync mailing list