Odd behavior in an exclude-file

Roy F. Cabaniss rcaban at housedraco.org
Mon Jan 5 04:02:52 GMT 2009

On Monday 22 December 2008 03:38:20 pm Matt McCutchen wrote:
> On Fri, 2008-12-19 at 10:01 -0600, Roy F. Cabaniss wrote:
> > rsync -avl --stats --progress --timeout=300 --exclude-from
> > "/home/foo/bin/exclude.txt" /home /mnt/sdc2
> >
> > Since there are, as with any backups, files I don't want to bother
> > backing up I created an exclude file and stored it in my bin.
> >
> >
> > - /home/foo/vmware
> > - /home/foo/.kde/share/apps/kmail/mail/spam/*
> > - /home/foo/.kde/share/apps/kmail/mail/.spam.directory/*
> > - /home/foo/.mozilla/firefox/tigy4u04.default/Cache
> > - /home/foo/packages
> > - /home/foo/.cxgames
> > - /home/foo/.cxoffice
> > - /home/foo/.beagle
> > - /home/foo/downloads/images
> >
> > With the rsync script in the /home/foo/bin I ran the script with myself
> > as root in the root directory.  Which leads to the reason for this
> > letter.
> >
> > The exclude file appears to have worked, with one exception.
> >
> > Much to my surprise, the images directory was
> > in the backup along with its contents.  I can assure you that the path is
> > as given.
> >
> > Is there any idea why I got that one directory in the backup?
> Perhaps run "od -t x1c" on the exclude file to see if there is anything
> funny about the last line.  E.g., if there is a trailing space, that
> would prevent the rule from matching.
> If that isn't it, you could see if the last rule works if you move it
> earlier in the exclude file, or if you change it to just "-
> images" (which probably excludes more than you want but could shed light
> on the problem).

Just to let everyone know:
I made sure there were a couple of spare line feeds after the last line.
I added a "dummy" exclude directory after the images line.

It worked fine then.
I don't know which of the two things I did was what made it work ok.  My guess 
would be the dummy exclude line because I did already have a linefeed after 
the last exclude line.

Thanks for the help.

Roy F. Cabaniss
At least one attached file is my gpg signature.  
If you don't know how to open/use the file, don't worry about it.  
It is included for those who DO know and understand such things.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
Url : http://lists.samba.org/archive/rsync/attachments/20090104/b1426456/attachment.bin

More information about the rsync mailing list