tricky rsync setup quit working

Peter Daum gator_ml at
Sat Sep 13 13:14:29 GMT 2008


some time ago I had started working on a rsync-based backup system.
After I longer break; I now tried to continue this project but can't
get it to work anymore. Maybe somebody here has any idea. The basic
setup looks like this:

$rsync $rsync_opts --rsh="'ssh -i $ssh_key'" $filesystems $bak_host::backup_module/path

on the server side, the ssh key triggered a shell script that generated
a configuration like

use chroot=1

and eventually invoked rsync with the command line:
rsync --daemon --no-detach --config $cfg_file

Back then, this setup actually worked: rsync read the configuration
file and started its work using the ssh-tunneled network connection.
In the syslog, this looked like this:
rsyncd: connect from UNKNOWN (localhost)
rsyncd: rsync to backup_module/hostname from UNKNOWN (localhost)
Now the same setup just causes rsync to listen on a new network socket

After looking through the documentation and digging in the rsync sources,
it doesn't look like this could ever work, but thrust me - it did!
(It looks like the only way to get rsync to honor the configuration file
is to specify --daemon, which causes it to listen on the network instead
of doing its work and the only way to do it's job on the existing network
connection is to specify "--server", in which case it doesn't honor the
configuration file. Unfortunately, some options like chroot can only be
specified via configuration file)

Unfortunately, I can't figure out what changed in the meantime that broke
this setup, Does anybody have an idea?

Any help would be greatly appreciated!

Peter Daum

More information about the rsync mailing list