rsync daemon not answering

Alejandro Celery acelery at
Fri Jun 13 15:43:17 GMT 2008

Matt McCutchen escribió:
> On Fri, 2008-06-06 at 10:02 -0300, Alejandro Celery wrote:
>> I have a problem: I was running rsync --daemon on a Ubuntu 6.10 linux 
>> without problems. I used it to sync our company intranet from a Windows 
>> host through deltacopy. Then I migrated my system to new hardware and 
>> installed Ubuntu 7.10 on it. I run rsync --daemon with the same 
>> rsyncd.conf file and it´s not listening to any requests. I´m trying to 
>> sync the same directories from the same deltacopy client and it´s not 
>> working. I do tcpdump on the rsync port and i confirm that the request 
>> from deltacopy are coming through OK and checked my iptables OK too. But 
>> for some reason the daemon doesn´t answer the requests.
>> Any idea what should I check? What should i post here to help you help me?
> Try connecting to the daemon locally by running "nc localhost PORT" on
> the daemon machine to see if the same thing happens.  If the daemon
> prints "@RSYNCD: 30" or "@RSYNCD: 29", then the problem is between there
> and the client.  If it doesn't print anything, then check the daemon's
> log and the syslog; the log should say something like "rsyncd version V
> starting, listening on port P".
> Matt
Hi everyone. I tried the advise Matt gave me about the netcat and got 
"@RSYNC: 30.0" (i updated it today tryng to fix this problem). So i 
gather that the daemon is working fine.
I have this doubt: I´m running Ubuntu 7.10 (gutsy) 64bit in this box. Is 
it possible that rsync on a 32bit Ubuntu cannot talk to rsync on a 64bit 
Ubuntu? Is the package that different? Here are the tests i tried and 
their results, maybe you can give me some clues. I have unrestricted 
access to all boxes except for the 7.04 one.

Source                     -      Dest
Ubuntu 6.10 32 bits - Ubuntu 7.04 32 bits - Connection OK
XP +SP2 32 bits      - Ubuntu 6.10 32 bits - Connection OK
Ubuntu 7.10 64 bits  - Ubuntu 6.10 32 bits - Daemon not answering
XP +SP2 32 bits      - Ubuntu 7.10 64 bits - Daemon not answering

Please help me! My flimsy backup strategy depends on the 64bit box 
rsyncing to the 6.10 one.

Alejandro Celery

More information about the rsync mailing list