My Rsync script is broken! Pls Help.

Matt McCutchen matt at
Thu Dec 4 02:26:31 GMT 2008

On Wed, 2008-12-03 at 17:33 -0800, likuidsilence wrote:
> I just found out smbfs has been deprecated for a long time now.. geez =( so I
> tried mounting the drive using cifs but no luck at all.. i still get those
> damn messages!! :confused:
> anyway, I was thinking of attaching my strace file but is 256mb in size!  I
> did see alot of "ENOENT" messages though (pasted below).. Thanks for your
> help.

> 6903  lstat64(".", {st_mode=S_IFDIR|0777, st_size=0, ...}) = 0
> 6904  select(1, [0], [], NULL, {60, 0} <unfinished ...>
> 6903  time(NULL)                        = 1228275069
> 6903  utimes(".", {1228275069, 0})      = -1 ENOTDIR (Not a directory)

This is what I wanted to see: the destination filesystem is not letting
rsync set directory mtimes.  There is nothing rsync can do about this.
If you want to preserve directory mtimes, you'll need to access the NAS
in a different way, preferably by rsync over ssh or an rsync daemon.  If
you don't care about directory mtimes, use -O to avoid the error


More information about the rsync mailing list