Script work fine on sheel, but no on a cron job

Jan-Benedict Glaw jbglaw at
Tue Oct 23 21:18:37 GMT 2007

On Tue, 2007-10-23 15:59:29 +0200, stephane.purnelle at <stephane.purnelle at> wrote:
> I make a script which make some call of rsync to connect to a rsync 
> daemon.
> When I run on a shell, the script work fine.
> When I run this scripts from a cron-job, the script fail with theses 
> messages : 
> rsync: failed to connect to remote-node: Connection refused (111)
> rsync error: error in socket IO (code 10) at clientserver.c(94)

Care to show us the script?  You'd debug this by either tcpdump'ing
the network traffic or by strace'ing one (or both) instances of the
rsync client/daemon.


      Jan-Benedict Glaw      jbglaw at              +49-172-7608481
 Signature of:                    Don't believe in miracles: Rely on them!
 the second  :
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url :

More information about the rsync mailing list