problems with permissions on windows

Mojca Miklavec mojca.miklavec.lists at
Thu Nov 8 22:55:29 GMT 2007


I'm using cwRsync on windows (I've tried a few alternatives, like
Delta for example, but all of them behave equally (bad) in my case -
they set really weird permissions on binaries - I don't know which
ones exactly, but binaries cannot be executed).

I have a linux server with binaries for different platforms. When I
rsync (copy) linux binaries to linux, or copy mac binaries to Mac OS
X, everything works fine, but if I try to rsync (copy) windows
binaries to a windows machine, I experience "permission problems" when
trying to run them.

All other files work OK (can be read and deleted), but .exe files don't.

I use
switches for rsync.

I need to explicitely execute "chmod 777 bin/*" after each rsync call
and I don't understand why. Original files have their permissions set
to 755.

- If I use vfat32 partition on a dual boot machine (Mac OS X) and copy
(rsync) windows binaries under linux, the binaries work fine when
switching back to windows.
- If I zip the files on the server, download the zip and extract files
on windows, the binaries also work OK.
- I should test once more. I experienced problems both on vfat32 and
ntfs, but under some circumstances the same thing worked on vfat32,
but not on ntfs.

Any help or hint about why this is happening would be greately appreciated.

Thanks a lot,

More information about the rsync mailing list