rsync hangs when accessing through SSH (Leopard OS X)

Greg Loesch gloesch.web at
Wed Dec 26 03:43:42 GMT 2007

Wayne Davison-2 wrote:
> Try some basic things:
> ssh user at true
> The above command should not output anything at all (excepting an ssh
> password prompt, if applicable).  If there is any output on stdout, you
> need to disable whatever is generating that output so that rsync doesn't
> get garbage trying to talk to the remote rsync.

This worked just fine

> ssh user at rsync --version
> The above command should show you rsync's version.  If it does not,
> figure out where rsync is installed and try it with a full path.  If a
> full path works, use the --rsync-path=/path/rsync option when invoking
> your client-side rsync.  If there is no rsync on the remote system,
> install it yourself.
> ..wayne..
> -- 
> To unsubscribe or change options:
> Before posting, read:
This, however, did the same thing that I'm having trouble with. Everything
just hangs. 

Okay, this may lead to a whole other mess, but I'm sure it needs to be
addressed. I attempted to uninstall rsync and reinstall from scratch not too
long ago, and I apparently am missing some important files. I searched the
database regarding uninstalling rsync and followed what I found. I deleted
the three files I was told to delete, and rsync still runs... I installed
rsync using fink if that makes things different? I tried doing a Spotlight
search for "rsync" and basically deleted everything that I saw, and it still
runs. Obviously there are some files that aren't indexed by Spotlight that
are slipping under the radar. I feel like I'm in a big mess now...

View this message in context:
Sent from the Samba - rsync mailing list archive at

More information about the rsync mailing list