pre-exec quit executing

Yan Seiner yan at
Fri Dec 7 16:47:45 GMT 2007

I'm trying to track down a mystery.

I have a remote box that's running rsync 2.6.9.  I tested it and 
everything worked fine for a while.

I use pre-xfer exec to mount the cifs shares that I will rsync and 
post-xfer exec to unmount them.  All of this worked fine in the shop and 
for the first two days on the customer's site.

The remote is running rsync in server mode from inittab:

rsync --deamon --no-detach

Now, for no apparent reason, the remote rsync won't:

log anything
run pre/post-xfer exec

Other options in the rsyncd.conf file work fine.

If I mount the cifs shares manually, rsync process normally.

I've intentially put bogus commands into the pre-post-xfer lines, and 
AFAICT they're just being ignored.

Since the remote is on a small appliance with 32 MB RAM, I thought maybe 
it's some sort of memory leak; I rebooted the box to eliminate that but 
no joy.

I am using rsync 2.6.9 on both sides.  Can anyone offer any suggestions 
on how to debug this?



More information about the rsync mailing list