xattr version generates 'wrong write used in receiver'

Steve Simmons scs at umich.edu
Fri Aug 31 15:17:45 GMT 2007

On Aug 30, 2007, at 6:57 PM, Steve Simmons wrote:

> On Aug 30, 2007, at 6:55 PM, Matt McCutchen wrote:
>> On 8/30/07, Steve Simmons <scs at umich.edu> wrote:
>>> Applying the xattr and acl patch to 2.6.9, running ./prepare-source
>>> and config with
>>>     ./configure --enable-xattr-support
>>> results in a version which fails to transfer with the error msg
>>> 'wrong write used in receiver' and complaints about protocol
>>> mismatch. I see there's a patch for a similar problem when
>>> SUPPORT_ACLS is defined; anybody done one for --xattrs?
>> http://lists.samba.org/archive/rsync/2006-November/016710.html
> Excellent, thanks.

One further followup on this - Apple's version of rsync -E has some  
sort of bug which seems to cause *all* attributes to be updated every  
time a sync is done, but only if both participants are intel-based  
OSX systems (go figure). It works fine ppc<->ppc and ppc<->intel.  
2.6.9 does not have this 'feature.'

Last night I ran some test syncs which updated about 11GB of a 90GB  
file system where most of changes were data, some were data and  
xattributes, and some were xattributes only. 2.6.9 worked fine with  
the patch above.

Many thanks to all involved.


More information about the rsync mailing list