Rsync hangs on large files over stunnel

Gene Quinn quinng00 at
Tue Oct 31 21:39:44 GMT 2006


Here's my setup:

On the server -
rsync 2.5.6  protocol version 26
stunnel 4.04 on i686-suse-linux-gnu PTHREAD with OpenSSL 0.9.7b

On the client - 
rsync  version 2.6.6  protocol version 29
stunnel 4.14 on i686-suse-linux-gnu UCONTEXT+POLL+IPv4+LIBWRAP with OpenSSL 0.9.8a

Both ends run rsync as root
The rsync daemon listens on a non-default port that is only bound to 127.0.01.  Stunnel securely proxies between an exposed high port and the rsync port.

The client is configured to pull from the server
The connection works.
Rsync starts
A series of small files are synchronized
The first moderately large file causes rsync to hang, typically at 66% completion.  The file is approximately 25 Meg.

netstat on both sides appears to show an established connection, but without any activity after the initial series of files are transferred.

I have tried using the --protocol option to force use of protocol 26.
I have tried using the --no-blocking-io

Any help you can offer is very much appreciated.



More information about the rsync mailing list