cwrsync server 2.0.4 / winxp / ownership problems?

Erik Jacobs erik.jacobs at
Mon Jan 30 21:25:01 GMT 2006

Hi all!

We're using cwrsync server 2.0.4 on winxp to keep files up to date between
some operator machines.

Whenever I run rsync to send files to another machine, the read-only flag
gets set.  The cwrsync user was created (the install is completely
standard)... so I'm thinking it might have something to do with that.

Here's my rsyncd.conf:

use chroot = false
strict modes = false
hosts allow = *
log file = rsyncd.log
pid file =

read only=false
comment=some stuff

When I run the following command from my laptop:
rsync -vzrLpogtu /stuff/windows/ user at node7::crystal_windows

It sets *ALL* the files in the /stuff/windows folder on the remote machine
to read-only.

This is a big problem because it means that when an operator goes to edit a
file in the windows folder with a program, he has to first make the file not
read only.

Is it possible to change the cwrsync configuration so that it runs as the
same user that the operator logs in as?  I'm thinking that for some reason
windows is getting confused and setting the ownership to the cwrsync user
and that's why the operator user sees the file as read-only.  Because the
operator is an administrator, the read-only can be turned off, but every
time rsync touches the folder it seems to reset all the permissions

Thanks in advance!

More information about the rsync mailing list