Problems with rsync, large files and partial.

Panos Koutsoyannis groovetronix at
Mon Apr 24 14:30:08 GMT 2006

I can't seem to get rsync to restart where it left off
when I am syncing a large file (> 5GB).  Below is some
info on what I have been doing.  If someone has the
energy to barrel through my comments that would be
great.  Out of curiosity is there an alternative to
rsync for large files?

I believe I looked all over the web for answers and I
found "partial" answers and just didn't seem clear if
this works.  If anyone has pointers or explanations it
would be most helpful.   Here is my set up and some

- I use rsync over ssh to sync over our wan.
- I sync over an 8 hour window every night.
- After 8 hours if the sync is not complete, it gets
killed and restarts the next evening.
- Everything works as expected except for one very
large file which always has to restart from the
beginning even though I use the partial command.
- I have tried it with and without compression.
- I have tried it with various versions of rsync
including the latest.
- There were some posts that seem to imply that if the
file already existed on the "backup system" and using
--append might help, but that didn't make sense.
- I have tried with whole-file and nowhole-file and
that does not make difference. 
- I do notice a bunch .file_name.gibberish in the
target  directory which is the partial backup, but it
does not seem to use them in subsequent tries.

It just seems the right thing to do would be for the
rsync to continue where it left off the night before,
but it doesn't.

- Here is my command
rsync --archive --verbose --progress -partial --stats
-e ssh


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the rsync mailing list