issues with password-file

Larry Hotchkiss larryhotch at
Sun Apr 2 15:55:38 GMT 2006

At 09:44 PM 4/1/2006 -0800, Wayne Davison wrote:
>On Fri, Mar 31, 2006 at 06:52:30PM -0600, Larry Hotchkiss wrote:
> > rsync -P -v -W -r --password-file=/path/secrets.rsync *
> > larry at xx.xx.xx.xx::lhotch/
>I assume you meant to say "test" there instead of "lhotch", since that's
>the module's name.
> > 2006/03/31 17:45:00 [3494] auth failed on module test from unknown
> > (xx.xx.xx.xx).
>If you upgrade to a more modern rsync, it will mention (in the log file
>only) the exact reason that the authorization failed.  It can be any
>number of reasons, from the user "larry" not being in the daemon's
>secrets file, the password not matching, etc.  Also, older rsyncs were
>particular about the files ending with a newline (which is fixed in
>newer versions).

Just an update, I upgraded to rsync 2.6.7 and the error is more clear in 
that it states a password mismatch but I double checked the contents of 
password-file=/path/secrets.rsync and the password matches what is 
contained in rsyncd.secrets file. To test the accuracy of the error I 
renamed the password-file=/path/secrets.rsync to something else but left 
the command unchanged and I got the identicle auth error which tells me 
that it will give a password mismatch if it cant find the password file as 

Thinking it may be a permission issue with rsync not being able to read the 
password file I changed its permissions to 777 and I still get the same error.

Can anyone shed any light?


More information about the rsync mailing list