error in rsync protocol data stream (code 12) at io.c(359)

stoil valchkov svalchkov at
Thu Nov 3 17:08:04 GMT 2005

It seems however that this issue maight have soemthing with permisions on
the client side. I've noticed that somehow rights of some directories are
changed during rsync-ing. So I've tried to reset rights (added write access
for owner) in all directoris recursievely after each rsync try. I don't know
if this was the reason but this is 1st time for more than 2 weeks now it
Do you have ideas what is the reason?

---------- Forwarded message ----------
From: stoil valchkov <svalchkov at>
Date: Nov 1, 2005 3:05 PM
Subject: error in rsync protocol data stream (code 12) at io.c(359)
To: rsync at


I've been experiencing this error for 2 weeks now. I don't now ehat could be
a reason. I've tried to update with latest sources, but the same result (I'm
not sure for line number, but the rest is the same).

rsync: connection unexpectedly closed (5881604 bytes received so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(359)

My synchronized data is about - 6.6GB & lot of files. It used to run without
problems but now it can't finish rvrn 1 time. Interesting part is that it
breaks often at the same place it was filed previous run (I have a loop in
shell script). I've checked source and destination rights - everything
should be fine. I've even deleted part of destination data. It didn't
succeed to download the deleted data.
So what could be a reason for this problem? Where can I look for possible
problems? Is it in rsync or in communication channel (I use ssh tunneling)?
Do you think that rsync server might do this better?

10x in advance!
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list