Fwd: error in rsync protocol data stream (code 12) at io.c(359)

stoil valchkov svalchkov at gmail.com
Tue Nov 8 09:28:19 GMT 2005

No solution yet :(
I tought that it is ok, but in fact it didn't run without problems. It was a
mistake in shell script and it finished with ok status and I tought rsync
finished with success.
How can I troubleshoot this?

Here is the command line:

rsync --partial --partial-dir=$partial_dir --timeout=$rsyncTimeout -vv
--compress --force -t -L --delete --rsync-path=/home/me/bin/rsync
de **something** --exclude=someBugUnimportandFile.xml
--include-from=rsyncInclude.txt  --exclude '*' --recursive me
@remoteHost:/remotepath /localPath &>  $rsyncLog

---------- Forwarded message ----------
From: stoil valchkov <svalchkov at gmail.com>
Date: Nov 1, 2005 3:05 PM
Subject: error in rsync protocol data stream (code 12) at io.c(359)
To: rsync at lists.samba.org


I've been experiencing this error for 2 weeks now. I don't now ehat could be
a reason. I've tried to update with latest sources, but the same result (I'm
not sure for line number, but the rest is the same).

rsync: connection unexpectedly closed (5881604 bytes received so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(359)

My synchronized data is about - 6.6GB & lot of files. It used to run without
problems but now it can't finish rvrn 1 time. Interesting part is that it
breaks often at the same place it was filed previous run (I have a loop in
shell script). I've checked source and destination rights - everything
should be fine. I've even deleted part of destination data. It didn't
succeed to download the deleted data.
So what could be a reason for this problem? Where can I look for possible
problems? Is it in rsync or in communication channel (I use ssh tunneling)?
Do you think that rsync server might do this better?

10x in advance!
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list