not deleting from the root

Paul Slootman paul at
Fri May 13 13:19:37 GMT 2005

On Fri 13 May 2005, Mike Zupan wrote:

> I have a bit of an issue with rsync. I am using to keep directories in
> sync via another server for backup.
> Here is the server config
> [w1]
> path = /w1
> comment = w1 web dir
> [w2]
> path = /w2
> comment = w2 web dir
> Now on the client i run this command
> rsync -avv --delete --force /w1/
> It will NOT delete anything that is no on the server anymore.. for

>From the rsyncd.conf manpage:

       read only
              The "read only" option determines whether clients will  be  able
              to  upload  files  or  not.  If  "read  only"  is  true then any
              attempted uploads will  fail.  If  "read  only"  is  false  then
              uploads will be possible if file permissions on the server allow
              them. The default is for all modules to be read only.

Note the last sentence...

> rsync -avv --delete --force /w1/apache/
> I'm stumped to why that works.. but the one above doesn't

That's because you're not accessing it via the module to delete that way.

Add a line
    read only = false
to the w1 module definition and it should work. However, you may also
need to take a look at the uid description in the same man page, in case
it still doesn't work...

Paul Slootman

More information about the rsync mailing list