Inheriting security permissions from target directory with Cygwin

Michael Carr mcarr at
Thu May 12 17:32:09 GMT 2005

I am trying to upload a directory structure with rsync via ssh from one
domain to another. I would like the target files (which may or may not
already exist on the target machine) to assume the security permissions of
the target directory they are placed into, since the target machine lies in
a different domain.
Currently, when I upload these files they seem to assume some strange random
security settings that I must invariably repair, which leads to a lot of
work for me. 
I tried using CYGWIN=nontsec on both the source and target sides and that
didn't seem to have any effect. Is there some rsync switch that tells rsync
on the target to ignore security settings on the files and to just use the
security settings of the parent directory they are placed into?
I tried using scp and it gives the same effect as rsync -- strange random
security settings on the target files.
I am using the latest cygwin version and have tried rsync 2.6.3, 2.6.4, and
    Michael Carr
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the rsync mailing list