rsync doesn't copy all files

Stuart Halliday StuartH at
Mon Jul 25 08:38:06 GMT 2005

> I live in Portugal.
> I have a Windows 2000 server with file sharing activated in my company.
> I have a linux box with a 200Gb disk for backups with rsync.
> I make an smbmount to /mnt/w2kbox then I use rsync like this:
> rsync -ar /mnt/w2kbox /200gb_disk
> The problem is that we use accents and cedillas and those files are not
> copied to the backup directory.
> Rsync says:
> file has vanished: "/mnt/w2kbox/Company Folders/Dep.
> Administrativo/JOANA/PRE??ARIOS EXPOSI??AO.xls"
> Some words with accents are copied but others not.
> Where is the problem? With the way I mount the w2k share or with rsync

I got this too when I try copying a few files with international characters in their names when copying from Win2000 to XP.
See rsync archives for details.

This one seems to have fixed it, thanks to Shachar Shemesh and Matt Langelino:

I fixed it (I think) by ensuring the language settings in both machines were set correctly to my local language.

More information about the rsync mailing list