protocol version mismatch

Arjen van der Meer ameer at
Tue May 25 14:35:46 GMT 2004


I am pretty new to rsync so this question might have a very trivial 
answer. Sorry for that then. (using google didn't work though)

I want to synchronise the files from my laptop to my machine at work and 
back from time to time. Both machines have linux (the laptop has fedora 
core 2 with a 2.6.6 kernel and the remote machine redhat 9 with a 
2.6.3 kernel)
On the laptop I use rsync v2.6.2 and on the remote machine I use v2.5.7

Using the following command:

  rsync -a /home/ameer/midastests remotemachine:/home/ameer/midastests

I get an errormessage:

  protocol version mismatch - is your shell clean?
  (see the rsync man page for an explanation)
  rsync error: protocol incompatibility (code 2) at compat.c(62)

I tried to use version v2.6.2 of rsync on the remotemachine, adding the 

This gave the same result. Also using v2.5.7 on the laptop gave the same 
result and a test between two remotemachines at work running the same 
versions gave the same.

Can somebody help me out with this? Thank you very much in advance

Cheers Arjen

More information about the rsync mailing list