One Truncated File in Rsynced Repository

Pete Toscano pete-rsync at
Fri Jul 16 13:54:44 GMT 2004

Hello all,

I keep all Fedora Core updates in a directory on my workstation.  I use
rsync to replicate this directory over to one of our servers that runs
our internal apt repository.  This has worked well for Red Hat Linux
7.3, Red Hat Linux 9, and Fedora Core 1, but there's something weird
happening with one file in the Fedora Core 2 updates.

I use the following to rsync my fedora core 2 updates directory:

rsync -e ssh --delete -rlptv /home/pete/updates/fedora/2/RPMS.updates/ server:/usr/local/repository/fedora/2/RPMS.updates/

The file's ethereal-0.10.5-0.2.1.i386.rpm.  When I download it, it's
4304935 bytes and the rpm -K (check sig) is good.  When I run the above
line, only 48796 bytes are copied to the server.  The rpm -K on the
server fails and the md5sums are different on both (obviously).

If I remove the file from the server and re-run the rsync, the same
thing happens.  If I scp the file over to the repository, then run rsync
at a later time, rsync over-writes the full version.

I've tried just "-av" instead of "-rlptv" and I tried adding "z" to the
end of the options.  None of this changes anything.

rsync --version returns: rsync  version 2.6.2  protocol version 28

Any ideas?  Am I just doing something stupid?  


More information about the rsync mailing list