Deleted files

Walls Rob W Contr 75 CS/SCBS Rob.Walls at
Tue Feb 24 16:35:46 GMT 2004

I am using mount -t smbfs. A log entry is made in /var/log/samba/smbmount
whenever I run the mount -t smbfs command, but no error or alert info is
provided when things act up. I can't see any smb errors happening, but rsync
for some reason is getting confused or getting the wrong info from the file
system. Could a network glitch slow down or break the file tests without
some kind of error being logged somewhere? I'm calling rsync with -vv. -vvv
gives me so much info, I haven't make sense of it...
The W2K share has 2000 directories and 74000 files. I run rsync every 10
min. Re-syncing normally takes about 1 min. My mirror script doesn't test if
rsync is running already, but that would probably be advisable.
Is there a way to determine if smbfs is not reading full directory lists?
Is there an upper limit on directory entries or dir read time with smbfs?
What about rsync limits?

Rob Walls

-----Original Message-----
From: jw schultz [mailto:jw at] 
Sent: Monday, February 23, 2004 5:30 PM
To: rsync at
Subject: Re: Deleted files

On Mon, Feb 23, 2004 at 05:04:00PM -0700, Walls Rob W Contr 75 CS/SCBS
> Thought my troubles were fixed, but files disappeared again and 
> reappeared after a few dozen rsync cycles. I am mapping a Win2K 
> directory to Linux with Samba. That mounted directory is then Rsynced 
> to another Linux box on a schedule (Linux to Linux, because I can't 
> run rsync on the windows machine). For some unknown reason, several 
> thousand files are periodically (after several days) deleted from the 
> remote Linux box. Running Rsync a few dozen times seems to get things 
> back to normal, but causes great stress to myself and my users.
> I am using the delete option, but these files should not be deleted,
> they haven't changed. Files eventually get back in sync. I can't figure
> why they are deleted in the first place.
> Any ideas on what to check? 

Firstly, smbfs on linux is related to samba but is not samba. By "mapping a
Win2K directory to Linux with Samba" i assume you mean "mounting a smb/cifs
share from a W2K server with smbfs on linux".  Assuming that clarification
is correct we can now procede.

Given that this simply doesn't seem to be happenning with
other filesystems i expect that either smbfs or the W2K
server are intermittantly dropping entries as readdir is
done.  It may be there is a bug in smbfs or even in W2K but
it may simply be that directory reading over smb cannot be
done coherently if there are long delays between readdir() calls on largish

If this were happening with local filesystems i would
suggest send_directory() be refactored (or do it myself)
to reduce the time spent with a directory open.

	J.W. Schultz            Pegasystems Technologies
	email address:		jw at

		Remember Cernan and Schmitt
To unsubscribe or change options:
Before posting, read:

More information about the rsync mailing list