Rsync / SSH / Cygwin .. permission problems..

Oswell, Michael moswell at
Fri May 30 03:02:02 EST 2003

I am attempting to use rsync to "mirror" data between several windows 2000
and windows XP systems.  I am a UNIX person by nature, so decided the
easiest way to go about doing this would be to use Cygwin with cron and ssh
running as services, then run the rsync connection nightly through cron.
Cygwin is installed on both systems and works perfectly.  OpenSSH is
installed and running, and the rsync user we created is able to ssh using
password-less keys between the 2 systems.  When I run rsync, it correctly
pulls the data down that I want.  The problem is that there are NO
permissions on the files that are pulled down, so they are basically
I have tried with and without the -p option, hoping the files would inherit
parent directory permissions if I didn't use it, but it doesn't appear to do
so. The command as I run it is;
rsync -rlztpv --rsh=ssh --delete remote-fs:/path/to/the/files .
rsync -rlztv --rsh=ssh --delete remote-fs:/path/to/the/files .
With the "p" option included, there are no permission bits set on the files
whatsover.  Without the "p" option, it sets the files to 0200.
Any ideas here?  Both systems have the Domain groups in the groups file, and
have the  rsync user as well as local users in the passwd file.  I would
prefer to not have to have ALL domain users in the password file for cygwin
if possible.
I have also tried this from a DOS shell instead of a cygwin shell with the
same results..
Thanks in advance...

More information about the rsync mailing list