Rsyncing Linux to OS X

a.h.s.boy spudlists at
Mon Mar 24 12:10:53 EST 2003

I'm trying to use rsync to backup some database files on a Linux box to 
an OS X machine, so I can write them to a tape drive connected to the 
OS X machine. I'm aware that there are some "issues" about rsync and 
certain file forks found on HFS+ filesystems, but I'm not sure that 
should be stopping me from accomplishing what I want to do.

I'm using rsync 2.5.5 on both machines, but the OS X version appears to 
be the RsyncX version (It says "HFS+ filesystem support for OSX (C)2002 
Kevin A. Boyd", but I have no recollection of having manually installed 
that version). I type in

rsync -e ssh -avz /backup/ praxis:/Volumes/Poursoi/Client1

to use SSH, archive mode and compression. The contents of /backup/ are 
about a dozen .tar.gz MySQL database files (I know uncompressed files 
will work better for rsync, but after those encountered the problem I'm 
describing, I tried compressing them). Upon execution, I get about a 

/bin/cp: dadatypo.tar.gz/rsrc: No such file or directory

which I assume is an attempt at synchronizing the "rsrc" fork that OS X 
is creating. I don't particularly care about those, so I don't care if 
they're missing.

However, I also see

stat dada_hosting.tar.gz : No such file or directory

...when the file plainly does exist.

On the receiving (OS X) end, only half of the files appear intact, and 
the others appear with names like:


I've tried using "--exclude="rsrc", but there was no difference.

Is there any way, or combination of options, that I can use to simply 
transfer these files intact? Would it help to uninstall the RsyncX 
version, and use plain ol' 2.5.5 on the OS X box?


a.h.s. boy
spud(at)            "as yes is to if,love is to yes"

More information about the rsync mailing list