Question regarding exclude and invalid arg messages

Morten Primdahl morten at
Mon Jun 30 17:42:57 EST 2003


I'm running rsync 2.5.6. I use it to backup a RH 7.3 file server 
(samba+appletalk) to a FAT32 external HD. I get the following output:

.1e6prS failed: Invalid argumentsp_ind/Emails ind/.Icon
.fJ98aa failed: Invalid argumentsp_ud/Emails ud/.Icon
.qLRVCT failed: Invalid argumentkt/02_Tegninger/planer/ai/.Icon
.zM65uw failed: Invalid argumentkt/02_Tegninger/planer/fmz/.Icon
mkstemp 2001_12_Villa_OpNed/01_Korrespondance ind/01 
Bygherre/Emails/.<None>.1.1.8sX6No failed: Invalid argument

What exactly constitutes the bad argument here? I'd guess the

Related question, I tried to use the same file for --exclude-from as I
use with tar -X, and incidentally it appeared to work. I only keep some
directory names in there, eg.

Temporary Items

These are directories created by the client machines and rsync does not
copy them to the destination. I tried to add .Icon in there and that did
not work as expected (I still get the above error messages). Any idea
why it would work for .AppleDouble but not .Icon? I know that it's
"luck" that the same exclude file works and that I should try and use
rsync exclude rules, but that doesn't explain .AppleDouble vs. .Icon.

Thanks for any enlightenment,


More information about the rsync mailing list