rsync over ssh: failed to connect to... after SuSE update

Klaus Haberkorn hk-EDV at
Wed Jan 8 10:06:00 EST 2003

I have been running rsync over ssh to a remote server without problems for months.
After an update from SuSE 7.2 to 8.1, I always get the following error:
"rsync: failed to connect to localhost: Connection refused
rsync error: error in socket IO (code 10) at clientserver.c(97)"
the rsync server port 873 is forwarded to 8073 on the client, so the client connects
to the server as localhost:8073. The ssh-connection seems to work, because I can do a
remote-login and issue commands on the remote server.
With a running ssh-connection, I tried to connect to the forwarded port with telnet
and got the following results:
telnet: connect to address Connection refused
(in local telnet window: when trying forwarded port 8073 -> 873)
channel_open_failure: 2: reason 2 Connection refused
(in remote ssh window: when trying forwarded port 5908 -> 5908)
ssh-command for the connection:
su - -c \
 "/usr/bin/ssh -l USER1 -C -p 69 SERVER1 \
 -L 5908:IP1:5908 \
 -L 8073:IP2:873"
USER1 is the username for the connection (local and remote are identical)
SERVER1 is the server address
IP1 and IP2 are IP-Adresses of forwarded servers.
rsync-command for the connection:
rsync -v --port=8073 --password-file=/etc/PASSWDFILE localhost::(...)
PASSWDFILE is the crypted password for the rsync-connection
(...) are the share-names of the rsync-server.
Probably there is a problem on my local system after the system update,
because all this worked fine before.
Trying the older ssh and rsync-versions leads to the same results.
Anybody an idea about that?
Thanks in advance Klaus.

More information about the rsync mailing list