Rsync fail repeatedly on the same files.

Addady addady at
Sun Sep 8 13:26:00 EST 2002


I’m trying to rsync Windows 2000 to Linux.  It fail on the same file every
in every try.

If  I delete from the source the problematic file, then it fail again after
a while on other file.  The file size vary etc.

I install rsync on other Linux for test, and there was no problem to rsync
the entire directory

to this new destination.

The error message on the client site is some thing like this:

rsync: error writing 14957 unbuffered bytes - exiting: Connection reset by

rsync error: error in rsync protocol data stream (code 12) at io.c(463)

I’m running 2.5.5 on both sides.

Tried to use --partial  and it still fail.

I install on the client side the cygwin patch for “connection reset by peer”
with no help.

I even download on the server side rsync version to 2.5.2 and it’s the same

It seems that the problem is on the server side.  This is our backup server
located on ISP

facility over seas.

Please advaise.


More information about the rsync mailing list